The difference between .width and .get_width().. is.. ginormous.

This is why I hate linux. This is why I hate coding. Why isn’t there a standardized way to write everything..

I’m so pissed off. Not a single reference online telling me that it should be get_width(). Take a look:

[extremely vague, doesn’t even tell me what members it has]:–get-allocation

[tells me it returns the size, doesn’t tell me anything that’s actually useful]:

[finally something useful, but gives me the wrong impression!]:

In fact, try google “get_allocation() width”, it’ll return a page of get_allocation().width or get_allocation().width()s..

I hate gtk. I hate linux. I hate coding.

So um yea, it should be get_allocation().get_width().. grrrrrrrrrrrrrrrrrrrrrrrrrr!